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CHAPTER 1
Introducing Flash Communication Server

Welcome to Macromedia Flash Communication Server MX—the easiest way to create rich
communication applications in Macromedia Flash MX. Flash Communication Server lets two or
more people participate in a real-time conversation using text, audio, or video. For example, you
can use Flash Communication Server for meetings, online communities, customer support, sales
support, training, remote presence, or instant messaging. Flash Communication Server is a
platform for streaming live data across networks for delivery to the Internet, PDAs, interactive
TV, and more, and it is part of Macromedia’s complete solution for database connectivity,
directory systems, and presence services. Flash Communication Server can also be used for
personal projects such as a house intercom, a pet camera, or video publishing.

Flash Communication Server editions

Flash Communication Server is available in a variety of editions. See the Flash Communication
Server website at http://www.macromedia.com/go/flashcom_mx for a description of each edition.
The information in the Flash Communication Server documentation applies to all Flash
Communication Server editions.

About this manual

This manual contains information to help you get started using Flash Communication Server and
the documentation set. It tells where to find all the other manuals and help systems, provides
system requirements and instructions for installing the software, presents an overview of the Flash
Communication Server architecture, and describes your workflow.

The Flash Communication Server documentation set assumes that you already have Macromedia
Flash MX installed and know how to use it.

Guide to instructional media

The Flash Communication Server instructional media is designed to be used in conjunction
with the Flash MX documentation, namely Using Flash MX and the Flash MX online
ActionScript Dictionary.

All Flash Communication Server documents are available in PDF format (viewable and printable
with Adobe Acrobat Reader) and as HTML help.

For the best experience with Flash Communication Server Help, Macromedia strongly
recommends that you use a browser with Java player support, such as Microsoft® Internet
Explorer 6.0 or later. Flash Help also supports Netscape 6.1 or later on Windows and the
Macintosh. Running Flash MX and Flash Communication Server Help simultaneously on a
Macintosh may require up to 32 MB of memory, depending on your browser’s memory needs.




If you choose Production Install, you can specify both the location of your client-side application
files (SWFs and HTMLs) and the location of your server-side application files (ASCs, FLVs, and
FLAs). The server will look for your client-side files under \flashcom\applications in the Web
server’s root directory and will look for your server-side application files under \applications
under the directory you specify.

System configuration
You can set up your software in one of a few configurations:

® You can install the Flash Communication Server software on the same computer that is
running Flash MX and the Flash Player.

® You can install the Flash Communication Server software on one computer and use another
computer for Flash MX and the Flash Player.

To install Flash Communication Server:

1 Locate the FlashComlInstaller.exe file.

This file is on your installation CD, or you may have downloaded it.

Double-click the installer icon. The installer launches.

Enter your name and serial number in the dialog box that appears. Click OK.

Read the license agreement and click Yes to accept the agreement.

g A~ W N

The installer suggests a default location for the server installation. The default location is
C:\Program Files\Macromedia\Flash Communication Server MX. Click Next to accept the
default location or Browse to choose another location.

6 Choose either the typical installation or a custom installation. (A typical installation is
recommended.) Click Next.

7 Enter the user name and password you have chosen. You must enter a password. The server
does not accept administrators with empty passwords.

The installer copies your user name and password into the server’s XML configuration
files. You can edit or add administrators later using the Administration Console.

g
For more information, see “Adding and editing administrators” in Managing Flash
Communication Server.

8 Choose Developer Install or Production Install. If you choose Production Install, you will be
asked to provide two directories: a directory for the Flash SWF files and accompanying
HTML files, and another directory for server-side files that should not be accessible to users
browsing your site. If you choose Developer Install, both types of files will be installed in the
same location.

9 Next, the installer suggests a location for the server administration tools and sample files,
including the Administration Console. If you have a web server installed on the same
computer, the installer asks if you want to install these files into the web server’s publishing
directory. You can install these files into the web server’s publishing directory or click Browse to
choose another location. Click Next when you are satisfied with the installation location.

10 Click Next to accept the new program icons.

M Click Next to accept the installer settings and install Flash Communication Server.
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12 Click Finish. The Flash Communication Server service starts up. The server runs as a
service, which means it runs in the background and starts automatically when the computer
is started up.

The installation is complete. If you choose not to start the Flash Communication Server service
right away, you can start it later. See “Starting and stopping the server” in Managing Flash
Communication Server.

About the installed files

When the server has been installed, you'll find several files together with it in the installation
directory. If you chose the default directory in the installer, these files are located in C:\Program
Files\Macromedia\Flash Communication Server MX\.

It’s a good idea to familiarize yourself with the contents of the Flash Communication Server MX
directory before continuing with this chapter. The Flash Communication Server MX directory
contains these items:

¢ FlashCom.exe is the server application.

® FlashComAdmin.exe is the server’s administration controller.

® License.htm contains the text of the Flash Communication Server license agreement.
® Js32.dll contains the server’s Server-Side Communication ActionScript engine.

® TcSrvMsg.dll, xmlparse.dll, and xmltok.dll are additional components of the server.
® The conf directory contains the server’s hierarchy of XML configuration files.

® The Tools directory contains BAT files that can be used to start and stop the server.

® The flashcom application directory contains sample client applications you can use to
experiment with the server and get an idea of the kinds of things that can be done with it. Also
included is the Administration Console (admin.swf) that you can use to connect to the server
to monitor and control its activity remotely.

® The admin directory contains the Administration Console (admin.swf), which you can use to
connect to the server to monitor and control its activity remotely.

® You can find running samples in \flashcom\applications and additional documentation
samples in flashcom_help\help_collateral, both of which can serve as templates for your own
applications.

® If you have Flash MX installed on the same computer, the Flash Communication Server
installer adds the new Communication App inspector and the NetConnection Debugger to
Flash MX. These provide support for creating and debugging communication applications.
For more information on using these features, see Developing Communication Applications.

Installing Flash authoring components on the Macintosh

To install the Communication App inspector, NetConnection Debugger, and related help files

into an existing copy of Macromedia Flash MX on a Macintosh computer, you use the Macintosh
FlashComlInstaller.
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To install the authoring components:
1 Locate the FlashComInstaller file.
This file is on your installation CD, or you may have downloaded it.

2 Double-click the installer icon. The installer launches. The installer locates your existing copy
of Flash MX automatically.

3 Click Install to install the authoring components and help. The installer copies files to your

hard disk.

When the installation is complete you can launch Flash MX and begin using the new windows to
create communication applications. For more information about creating communication
applications, see Developing Communication Applications.
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How Flash Communication Server works

The Flash Communication Server platform comprises the server that provides the means of

communication and a Flash application (a SWF file that runs in Macromedia Flash Player) that
. ) .

provides the end user’s interface. You use the Flash MX authoring tool as your development

environment to create applications that use Flash Communication Server services. You can also

use server-side scripting to add functionality to your application.

Communications pass through Flash Communication Server and are delivered to the client—the
Flash Player on a user’s computer. When a Flash movie uses Flash Communication Server, the
player connects to the server, which provides a flow of information, called a network stream, to
and from the client. Other users can connect to the same server and receive messages, data
updates, and audio/video streams.

Flash Communication Server
|

———l| Sends/receives

— data stream

Clients running the Flash Player

You can design Flash Communication Server applications so that the Flash Communication
Server and the application server communicate with each other. Flash Communication Server can
talk to other application servers such as Macromedia ColdFusion MX Server, Macromedia JRun,
Microsoft® .NET Framework, IBM WebSphere, and Apache Tomcat. For a more detailed
explanation, see Developing Communication Applications.
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Client connections to Flash Communication Server use the Real-Time Messaging Protocol
(RTMP), which, unlike HTTP, provides a persistent socket connection for two-way
communication between Flash Player clients and the Flash Communication Server.

Web server
|

Sends SWF

Client
|

Plays SWF using
Flash Player

' 12,

Flash Communication Server

|
— Sends/receives
[— data stream
(o]

Flash Communication Server applications include two basic items: a server-side data stream that
plays from the server thin client, and shared objects.

Sever-side data stream  The server-side data stream is managed by two objects: the
NetConnection object and a Stream object.
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The NetConnection object tells the Flash Player to connect to an application on the server. You
can use NetConnection objects to create powerful Flash Communication Server applications. For
example, you could get weather information from an application server, or share an application
load with other Flash Communication Servers or application instances.

The Stream object lets you handle each stream in a Flash Communication Server application. A
user can access multiple streams at the same time, and there can be many Stream objects active at
the same time.

Shared objects  Shared objects are used to store data from the client. They let you manage
distributed data with ActionScript in the Flash Player. If youre a developer, you can use shared
objects to create your own models for how the data is managed.

For more information about NetConnection objects, Stream objects, and shared objects, see
Developing Communication Applications.

How do | use Flash Communication Server?

The following sections describe your workflow, depending on what you intend to do with Flash
Communication Server.

For the locations of the manuals mentioned in the following sections, see Guide to instructional
media.
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Developer workflow

If you're a developer, you can create a Flash Communication Server application that has a client
component and, if needed, a server component. The client component is a Flash MX movie
(SWF) that you develop using Client-Side Communication ActionScript, and the server
component is a program you write using Server-Side Communication ActionScript. After you
create the application, register it on the Flash Communication Server; if there are any server-side
scripts, upload them to the Flash Communication Server. You can then test the application using
the Flash Player to connect to the server. While you're testing the movie, you can debug it using
the NetConnection Debugger and the Communication App inspector. After the application
works propetly, you can deploy it.

SWF file Flash Communication Server

h Create using
p— client-side
ActionScript

Server-side scripts

—l_‘ Flash Player
Create using
server-side
ActionScript
Test SWF

J

NetConnection Debugger
Communication App inspector

Register application
with server

Debug
application

Deploy

Clients running the Flash Player
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The following resources will help you develop Flash Communication Server applications.

Tobegin To get started in the development process, begin with Developing Communication
Applications. This manual describes how to connect to the Flash Communication Server. It also
supplies samples that you can use as templates for creating, testing, and debugging applications.
To use these samples, open the directory where Flash MX is installed, and go to
\flashcom_help\help_collateral\.

Scripting  For scripting reference, consult the following manuals:

® The Client-Side Communication ActionScript Dictionary explains the ActionScript commands
you use in the Flash MX authoring environment.

® The Server-Side Communication ActionScript Dictionary explains the ActionScript commands
you use in scripts that reside on the server.

® Using Flash MX describes how to write basic ActionScript, presents samples, and provides
references to additional instructional media that can assist you in becoming a Flash
developer. Using Flash MX is available in printed form and as a help system (select Help >
Using Flash MX).

Testing and debugging When you're ready to test and debug your application, use the
Communication App inspector and the NetConnection Debugger.

® The Communication App inspector lets you view detailed server information when the
application is running. To open this inspector, in Flash MX select Window >
Communication App Inspector. When the inspector is open, you can view online help by
clicking the Help button.

® The NetConnection Debugger lets you debug applications when they are running. To open
this debugger, in Flash MX select Window > NetConnection Debugger. When the debugger is
open, you can view online help by clicking the Help button.

Additional resources  You may want to explore these other sources of information on Flash
Communication Server:

® The Flash Communication Server Support Center at http://www.macromedia.com/go/
flashcom_support provides TechNotes and up-to-date information about Flash
Communication Server.

® The Flash Communication Server Designer & Developer Center at htep://
www.macromedia.com/go/flashcom_desdev provides tips and samples for creating Flash
Communication Server applications.
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Administrator workflow

If you're an administrator, you'll use the Administration Console to configure Flash
Communication Server, set up system security, monitor usage, start and stop the server, and

add users.

Flash Communication Server

Sends/receives
data stream

—
-—

Administration Console

Clients running the Flash Player

Configuration
Security
Monitoring usage

Use the following resources to help you manage Flash Communication Server:

* Managing Flash Communication Server tells how to use the Administration Console to install,
manage, start and stop, and configure the Flash Communication Server.

® To read online help, open the Administration Console (in Windows, select Start > Programs >
Macromedia Flash Communication Server MX > Server Administrator) and select the

appropriate documentation.

® The Flash Communication Server Support Center at http://www.macromedia.com/go/
flashcom_support provides TechNotes and up-to-date information about Flash
Communication Server.

® The Flash Communication Server Designer & Developer Center at htep://
www.macromedia.com/go/flashcom_desdev provides tips and samples for creating Flash
Communication Server applications.
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GLOSSARY
Flash Communication Server Terms

application server ~ Software that helps a web server process web pages that contain server-side
scripts or tags. When such a page is requested, the web server sends the page to the application
server for processing before sending the page to the browser.

Common application servers include Macromedia ColdFusion MX Server, Macromedia JRun,

Microsoft NET Framework, IBM WebSphere, and Apache Tomcat.

HTTP (Hypertext Transfer Protocol) The communication protocol used to connect to servers on
the World Wide Web. HTTP’s primary function is to establish a connection with a web server
and transmit HTML pages to a client browser.

NetConnection object The object that tells the Flash Player to connect to an application on
the server.

Real-Time Messaging Protocol (RTMP) The communication protocol that provides persistent
socket connection for two-way communication between Flash Player clients and the Flash
Communication Server.

shared objects  Objects used to store data locally or remotely.

stream object  An object that lets you handle each stream in a Flash Communication Server
application.

streaming audio The continuous transmission of audio over a data network.
streaming video The continuous transmission of video over a data network.

thin client A user’s computer that stores nothing locally but downloads the program from a
server. It performs normal computer processing, but stores data on the server.

web client The client side (user side) of the web. A web client can be the user’s web browser,
plug-ins, or other applications that support the browser.

web server  Software that sends web pages in response to requests from web browsers.

21



	Contents
	Introducing Flash Communication Server
	Flash Communication Server editions
	About this manual
	Guide to instructional media
	Using additional resources
	Release notes
	Third-party resources


	Installation and Workflow
	System requirements for Flash Communication Server
	Development
	Deployment

	System requirements for the Flash Player
	Installing Flash Communication Server
	System configuration

	About the installed files
	Installing Flash authoring components on the Macintosh
	How Flash Communication Server works
	How do I use Flash Communication Server?
	Developer workflow
	Administrator workflow


	Flash Communication Server Terms



